all repos — m12-patcher @ dd1011c2941c816701ba774ad5c727c6d7ff84b1

patcher.spec (view raw)

 1# -*- mode: python ; coding: utf-8 -*-
 2
 3
 4block_cipher = None
 5
 6
 7a = Analysis(
 8    ['patcher.py'],
 9    pathex=[],
10    binaries=[],
11    datas=[('patcher.ui', '.')],
12    hiddenimports=['pygubu.builder.ttkstdwidgets', 'pygubu.builder.tkstdwidgets'],
13    hookspath=[],
14    hooksconfig={},
15    runtime_hooks=[],
16    excludes=[],
17    win_no_prefer_redirects=False,
18    win_private_assemblies=False,
19    cipher=block_cipher,
20    noarchive=False,
21)
22pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
23
24exe = EXE(
25    pyz,
26    a.scripts,
27    a.binaries,
28    a.zipfiles,
29    a.datas,
30    [],
31    name='patcher',
32    debug=False,
33    bootloader_ignore_signals=False,
34    strip=False,
35    upx=True,
36    upx_exclude=[],
37    runtime_tmpdir=None,
38    console=False,
39    disable_windowed_traceback=False,
40    argv_emulation=False,
41    target_arch=None,
42    codesign_identity=None,
43    entitlements_file=None,
44)