tools/debian/rules (view raw)
1#!/usr/bin/make -f
2
3# Copyright (C) 2015 Sergio Benjamim
4
5# This Source Code Form is subject to the terms of the Mozilla Public
6# License, v. 2.0. If a copy of the MPL was not distributed with this
7# file, You can obtain one at http://mozilla.org/MPL/2.0/. */
8
9DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
10
11%:
12 dh $@ --buildsystem=cmake --builddirectory=obj --parallel
13
14override_dh_auto_configure:
15 dh_auto_configure -- -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_SKIP_RPATH=ON -DBUILD_LIBRETRO=ON
16 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' \
17 debian/libretro-mgba.install.in > debian/libretro-mgba.install
18 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' \
19 debian/libmgba.install.in > debian/libmgba.install
20
21override_dh_installchangelogs:
22 dh_installchangelogs -k CHANGES