all repos — mgba @ d4e7bf68622768a1d9e7a97c0f1160ef7b478eaa

mGBA Game Boy Advance Emulator

tools/debian/rules (view raw)

 1#!/usr/bin/make -f
 2
 3# Copyright (C) 2015 Sergio Benjamim
 4
 5# This Source Code Form is subject to the terms of the Mozilla Public
 6# License, v. 2.0. If a copy of the MPL was not distributed with this
 7# file, You can obtain one at http://mozilla.org/MPL/2.0/. */
 8
 9DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
10ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
11
12ifeq ($(ARCH),armhf)
13	ARM=-DBUILD_GL=OFF -DBUILD_GLES2=ON
14endif
15
16%:
17	dh $@ --buildsystem=cmake --builddirectory=obj --parallel
18
19override_dh_auto_configure:
20	dh_auto_configure -- -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_SKIP_RPATH=ON -DBUILD_LIBRETRO=ON $(ARM)
21	sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' \
22		debian/libretro-mgba.install.in > debian/libretro-mgba.install
23	sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' \
24		debian/libmgba.install.in > debian/libmgba.install
25
26override_dh_installchangelogs:
27	dh_installchangelogs -k CHANGES